≡ Menu

Fancy Maze Case 01

.

Fancy Maze Case01 is another Japanese/English point and click type escape the room game. You can choose the language, click yellow button in the bottom left corner. There are two endings in this game.Takes a long time to load, please be patient.

Play Fancy Maze Case 01


{ 16 comments… add one }

  • dewers79 August 23, 2010, 9:48 am

    SO far I have an I pod lookin thingy (which I assume I have to charge), a red and green part, 2 notes and a paperclip (used) and a magizine………..

    has anyone gotten ay furthur?

  • Anonymous February 27, 2010, 9:09 pm

    i didnt get any trouble with loading.. idk what yalls problem is.

  • tdafreak December 13, 2009, 12:22 pm

    OMG that is a long time to load.

  • LOL? December 1, 2009, 4:02 pm

    HEW EVER RADS THIS IS A BITCH

  • Adan90 November 17, 2009, 3:39 pm

    i took same as meep away

  • kyon November 17, 2009, 3:37 pm

    Fuuuuuuuuuuuuuuuuuuuuuuuuuuuuuuuuuuuuuuuuuuuuuuuuuuuuuuuuuuuuuuuuuuuuuuuuuuuuuuuuuuuuuuuuuuuuuuuuuuuuuuuuuuuuuuuuuuuuuuuuuuuuuuuuuuuuuuuuuuuuuuuuuuuuuuuuuuuuuuucccccccccccccccccccccccccccccccccccccckkkkkkkkkkkkkkkkkkkkkkkkkkkkkkkkkk!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!

  • Adan90(same as Meep) November 17, 2009, 3:36 pm

    My fake name is the same as on adventur qust worlds(aqw)

    • tdafreak December 13, 2009, 12:21 pm

      i luv adventure quest worlds! i played it 4 awhile until I lost my password. =(

  • Meep November 17, 2009, 3:33 pm

    yes kyon that was a stupid commet

  • Kyon November 9, 2009, 5:42 pm

    Ohh…. It’s ok now. I can only open the options menu during gameplay. Sorry for the dum comment. ^^”

  • Kyon November 9, 2009, 5:36 pm

    I can’t change the language. I tried pressing the yellow button in the lower left corner, beside the green button, but nothing happens… please help.

  • Abbie November 7, 2009, 11:34 am

    not even worth PLAYING

  • Point and Click Games November 1, 2009, 11:13 am

    Link has been fixed, thanks for reporting!

  • xcona October 29, 2009, 11:02 am

    dosnt work

  • Roo October 29, 2009, 8:07 am

    They weren’t kidding when they said it takes a long time to load…

    …6 minutes and counting…

    • Roo October 29, 2009, 8:13 am

      After almost 10 minutes waiting…I got a 502 Bad Gateway Error…

      Bah!

Leave a Comment

Next post:

Previous post: